sexta-feira, 19 de maio de 2017

Corrigindo o bug "Use gi.require_version ('Notify', '0.7') before import to ensure that the right version gets loaded."

 Se o erro abaixo aparecer:

"PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version ('Notify', '0.7') before import to ensure that the right version gets loaded. from gi.repository import Notify"

corrigi-lo é muito fácil. Basta instalar o pacote gir1.2-appindicator3-0.1 segundo o procedimento padrão para sua distro, o que não será visto aqui.

Para o Ubuntu e distros derivadas:

$ sudo apt-get install gir1.2-appindicator3-0.1

Para Debian e distros derivadas:

$ su - [ENTER]
# apt-get install gir1.2-appindicator3-0.1
# exit

Até a próxima dica!
;-))

Nenhum comentário:

Postar um comentário