quarta-feira, 15 de fevereiro de 2017

Corrigindo o erro "Nautilus was imported without specifying a version first. Use gi.require_version('Nautilus', '3.0')" no Debian, Ubuntu e derivadas

Se você não consegue abrir o gerenciador de arquivos nautilus, devido ao erro abaixo, que aparece ao chamá-lo no terminal:

"sys:1: PyGIWarning: Nautilus was imported without specifying a version first. Use gi.require_version('Nautilus', '3.0') before import to ensure that the right version gets loaded. No modules named requests".


Abra um terminal e digite:

UBUNTU E DERIVADAS
$ sudo apt-get install python-requests

DEBIAN (todas as versões) E DERIVADAS
$ su - [ENTER]
# apt-get install python-requests
# exit

Nas outras distros, procure o equivalente a este pacote e instale-o segundo o procedimento padrão para elas, o que não será visto aqui.

Até a próxima dica!
;-))

Nenhum comentário:

Postar um comentário