sábado, 2 de abril de 2016

Corrigindo o erro "Cache file /var/cache/pdnsd/pdnsd.cache ignored because of incompatible version identifier" no linux

Para corrigir o erro "Cache file /var/cache/pdnsd/pdnsd.cache ignored because of incompatible version identifier", após a instalação do pdnsd na sua distro favorita, siga os passos abaixo, no terminal, como super usuário:

DEBIAN E OUTRAS DISTROS
$ su -
# nano /var/cache/pdnsd/pdnsd.cache

ou

UBUNTU E OUTRAS DISTROS
$ sudo nano /var/cache/pdnsd/pdnsd.cache

Ao abrir o arquivo-texto pdnsd.cache, você encontrará a linha abaixo:


Basta removê-la e reiniciar o pdnsd, segundo o padrão para sua distro. No caso do systemd, faça como superusuário:

DEBIAN E OUTRAS DISTROS
$ su -
# systemctl restart pdnsd.service

ou

UBUNTU E OUTRAS DISTROS
$ sudo systemctl restart pdnsd.service

Veja que o cabeçalho mudou, corrigindo o bug:


Veja agora com o systemd:

DEBIAN E OUTRAS DISTROS
$ su -
# systemctl status pdnsd.service


ou

UBUNTU E OUTRAS DISTROS
$ sudo systemctl status pdnsd.service


Até a próxima dica!
;-)

Nenhum comentário:

Postar um comentário