sexta-feira, 26 de setembro de 2014

Corrigindo o bug "shellshock" no ubuntu e derivadas

Não vou entrar em detalhes, mas o Ubuntu já liberou atualização para o bash para a vulnerabilidade conhecida como "Shellshock". Rode os comandos abaixo no terminal, na ordem: 

$ sudo apt-get update
$ sudo apt-get dist-upgrade bash

Isso será o suficiente. Mas se você quiser tirar a prova, rode o comando abaixo no mesmo terminal:

$ env x='() { :;}; echo vulnerable' bash -c 'echo hello'
bash: aviso: x: ignoring function definition attempt
bash: erro ao importar a definição da função para `x'
hello

O Debian também corrigiu o bug e as distros baseadas em pacotes rpm deverão liberar suas correções o mais rápido possível.

Até a próxima dica!
;-))

Nenhum comentário:

Postar um comentário