quinta-feira, 22 de dezembro de 2011

E: O driver do método /usr/lib/apt/methods/https não pode ser encontrado.

Caso você receba este alerta ao rodar o "apt-get update", seja no terminal ou no synaptic, não se preocupe. Significa que um dos repositórios está errado, em /etc/apt/sources.list.

Para corrigi-lo abra o arquivo de configuração e conserte o repositório errado. A mensagem "...método /usr/lib/apt/methods/https..." mostra erro em endereço que começa com "https", e não "http" como padronizado.

Faça na ordem:

ubuntu
$ sudo nano /etc/apt/so*t

debian
$ su + senha de root + [enter]
# nano /etc/apt/so*t

Se encontrar uma linha assim (exemplo):

deb https://br.archive.ubuntu.com/ubuntu/...

Deixe-a assim:

deb http://br.archive.ubuntu.com/ubuntu/...

Salve e rode o update novamente. Você verá que o erro desapareceu para nunca mais voltar...

Até a próxima dica!
;-))

10 comentários:

  1. Tá tudo em http e o erro continua :\

    ResponderExcluir
    Respostas
    1. dê uma olhada no arquivo sources.list e veja se há alguma linha errada segundo o exemplo acima. os endereços podem conter mais erros.

      Excluir
  2. Muito bom amigo, valeu!

    ResponderExcluir
    Respostas
    1. Muito obrigado. Divulgue-o a seus amigos. Volte sempre. ;-))

      Excluir
  3. o meu ainda continua o erro. já olhei o arquivo sources.list e não tem o erro menciona acima. me ajude

    ResponderExcluir
    Respostas
    1. olhe dentro da pasta /etc/apt/sources.list.d e veja se tem repositórios dentro. se ainda aparece o erro pode estar aqui ou no sources.list, que passou despercebido.

      Excluir
  4. nao entendo nada disso daria para ser mais especifico para saber como chego nesses arquivos?

    ResponderExcluir
    Respostas
    1. A dica foi feita da forma mais simples possível, mas necessita algum conhecimento de linx, porparte do usuário. Recomendo cadastra-se e tirar suas dúvidas em www.vivaolinux.com.br. Lá você encontra uma equipe muito boa, que pode orientá-lo. ;-)

      Excluir